Jelou - WhatsApp Messaging Service – Increased Latency & Delayed Delivery – Detalles del incidente

Sistemas funcionando con normalidad

WhatsApp Messaging Service – Increased Latency & Delayed Delivery

Resuelto
Interrupción mayor
Iniciado el hace 24 díasDuró 42 minutos

Afectado

Channels

Interrupción mayor de 8:55 PM a 9:20 PM, En funcionamiento de 9:20 PM a 9:37 PM

WhatsApp

Interrupción mayor de 8:55 PM a 9:20 PM, En funcionamiento de 9:20 PM a 9:37 PM

Actualizaciones
  • Después de la muerte
    Después de la muerte

    Incident Summary

    An overload was recorded in the bot system that limited its ability to process incoming messages in a timely manner. As support resources became saturated, the service experienced excessive wait times, preventing end users from receiving automated responses during the event.

    Impact

    The impact was limited to the interruption of service flows that depend on real-time message processing and user responses. Static or independent flows continued to run normally.

    Detection

    The incident was identified through automatic performance alerts and high latency in bot responses, in addition to reports from the support team and customers experiencing failures in digital signature flows. This confirmed service degradation in the processing of interactive messages.

    Response

    Once the issue was identified, the engineering team diagnosed the root cause and deployed a fix in under 30 minutes from escalation, increasing the performance and capacity of the resources supporting the bot to normalize the service.

    Root Cause

    The incident was triggered by a mass event caused by the simultaneous sending of campaigns by two customers. This generated a sudden and concentrated spike in activity volume that exceeded the response speed of the automatic scaling mechanisms, preventing the system from reacting in time to contain the load and causing temporary resource saturation.

    Resolution

    As a definitive resolution, scaling controls were adjusted and the base performance capacity of the bot infrastructure was increased. This adjustment ensures the system has the necessary headroom to absorb mass events and sudden activity spikes without degrading service.

  • Resuelto
    Resuelto
    This incident has been resolved.
  • Supervisando
    Supervisando
    We implemented a fix and are currently monitoring the result.
  • Investigando
    Investigando

    WhatsApp messages are currently experiencing delays in responses. We are currently investigating this incident.