Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2024 - 23:45 GMT-05:00
Scheduled
We will be undergoing synchronized maintenance with Meta for the WhatsApp channel on Sunday from 23:45 to 00:30. Please note that interruptions or delays may occur during this period. Our team aims to keep the maintenance window as short as possible to enhance service quality. For any questions or concerns, feel free to reach out to us at ayuda@jelou.ai. We appreciate your understanding.
Posted Mar 15, 2024 - 17:05 GMT-05:00
This scheduled maintenance affected: Channels (WhatsApp).