Civil Register Unavailability
Incident Report for Jelou
Resolved
Civil Register confirms that the event has been resolved.
Posted Oct 23, 2024 - 11:05 GMT-05:00
Investigating
Civil Register is currently investigating this issue.
Posted Oct 23, 2024 - 08:28 GMT-05:00
This incident affected: External Services (Civil Register - Ecuador).