WhatsApp Delay

Incident Report for Jelou

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 16:50 GMT-05:00

Investigating

We are currently experiencing issues with WhatsApp Flows. These are direct WhatsApp issues and will be updated.
Posted Aug 13, 2025 - 15:55 GMT-05:00
This incident affected: Channels (WhatsApp).