OTP emails going to spam

Incident Report for Jelou

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 19:33 GMT-05:00

Investigating

Since 10:03, we have been receiving reports of OTP emails not arriving. This issue is related to the email provider. Please check if the email is in the spam folder.
Posted Mar 24, 2025 - 11:36 GMT-05:00